TypeLoadException running PabloDraw 3.1.2 in Ubuntu 12.04 64-bit

Home Forums PabloDraw General TypeLoadException running PabloDraw 3.1.2 in Ubuntu 12.04 64-bit

This topic contains 3 replies, has 2 voices, and was last updated by  Ragnarok 6 years, 11 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #2229 Reply

    JP

    As the readme instructed, I have Mono 2.10.8 and gtk-sharp installed from the ubuntu repositories. When I run “mono PabloDraw.exe” I get this error:

    Unhandled Exception: System.TypeLoadException: A type load exception has occurred.
    at PabloDraw.Startup.Main (System.String[] args) [0x00000] in :0
    [ERROR] FATAL UNHANDLED EXCEPTION: System.TypeLoadException: A type load exception has occurred.
    at PabloDraw.Startup.Main (System.String[] args) [0x00000] in :0

    Any idea what could be causing this?

    #2231 Reply

    Curtis Wensley
    Keymaster
    Post count: 77

    Probably still missing additional packages. Ubuntu 12.04 has split things up quite a bit. I was able to get PabloDraw to work after installing the monodevelop package.

    Hope this helps!
    Curtis

    #2232 Reply

    JP

    That did the trick. Thank you very much! The monodevelop dependency should definitely go in the readme.

    #2243 Reply

    Ragnarok

    hi! i dont want install all of that libs!

    can you helpme to identify only real required libs to install?

    mono development hay similar tool to LDD to detect what libs needs??

    — cut —
    Se instalarán los siguientes paquetes NUEVOS:
    libglade2.0-cil-dev libglib2.0-cil-dev libgtk2.0-cil-dev libmono-2.0-1 libmono-2.0-dev libmono-addins-gui0.2-cil libmono-addins0.2-cil libmono-c5-1.1-cil libmono-cairo2.0-cil
    libmono-cecil-private-cil libmono-cil-dev libmono-codecontracts4.0-cil libmono-compilerservices-symbolwriter4.0-cil libmono-cscompmgd8.0-cil libmono-csharp4.0-cil
    libmono-custommarshalers4.0-cil libmono-db2-1.0-cil libmono-debugger-soft2.0-cil libmono-debugger-soft4.0-cil libmono-http4.0-cil libmono-i18n-cjk4.0-cil libmono-i18n-mideast4.0-cil
    libmono-i18n-other4.0-cil libmono-i18n-rare4.0-cil libmono-i18n2.0-cil libmono-i18n4.0-all libmono-ldap2.0-cil libmono-management2.0-cil libmono-management4.0-cil
    libmono-messaging-rabbitmq2.0-cil libmono-messaging-rabbitmq4.0-cil libmono-messaging4.0-cil libmono-microsoft-build-engine4.0-cil libmono-microsoft-build-framework4.0-cil
    libmono-microsoft-build-tasks-v4.0-4.0-cil libmono-microsoft-build-utilities-v4.0-4.0-cil libmono-microsoft-build2.0-cil libmono-microsoft-csharp4.0-cil libmono-microsoft-visualc10.0-cil
    libmono-microsoft-web-infrastructure1.0-cil libmono-microsoft8.0-cil libmono-npgsql2.0-cil libmono-npgsql4.0-cil libmono-opensystem-c4.0-cil libmono-oracle2.0-cil libmono-oracle4.0-cil
    libmono-peapi2.0-cil libmono-peapi4.0-cil libmono-rabbitmq2.0-cil libmono-rabbitmq4.0-cil libmono-relaxng2.0-cil libmono-relaxng4.0-cil libmono-sharpzip2.6-cil libmono-sharpzip4.84-cil
    libmono-simd2.0-cil libmono-simd4.0-cil libmono-sqlite4.0-cil libmono-system-componentmodel-composition4.0-cil libmono-system-componentmodel-dataannotations4.0-cil
    libmono-system-configuration-install4.0-cil libmono-system-data-datasetextensions4.0-cil libmono-system-data-linq4.0-cil libmono-system-data-services-client4.0-cil
    libmono-system-data-services4.0-cil libmono-system-design4.0-cil libmono-system-drawing-design4.0-cil libmono-system-dynamic4.0-cil libmono-system-identitymodel-selectors4.0-cil
    libmono-system-identitymodel4.0-cil libmono-system-ldap2.0-cil libmono-system-ldap4.0-cil libmono-system-management4.0-cil libmono-system-messaging4.0-cil libmono-system-net4.0-cil
    libmono-system-numerics4.0-cil libmono-system-runtime-caching4.0-cil libmono-system-runtime-durableinstancing4.0-cil libmono-system-runtime-serialization-formatters-soap4.0-cil
    libmono-system-runtime-serialization4.0-cil libmono-system-runtime2.0-cil libmono-system-runtime4.0-cil libmono-system-servicemodel-discovery4.0-cil
    libmono-system-servicemodel-routing4.0-cil libmono-system-servicemodel-web4.0-cil libmono-system-servicemodel4.0-cil libmono-system-serviceprocess4.0-cil
    libmono-system-web-abstractions4.0-cil libmono-system-web-applicationservices4.0-cil libmono-system-web-dynamicdata4.0-cil libmono-system-web-extensions-design4.0-cil
    libmono-system-web-extensions4.0-cil libmono-system-web-mvc1.0-cil libmono-system-web-mvc2.0-cil libmono-system-web-routing4.0-cil libmono-system-web-services4.0-cil
    libmono-system-web4.0-cil libmono-system-xaml4.0-cil libmono-system-xml-linq4.0-cil libmono-tasklets2.0-cil libmono-tasklets4.0-cil libmono-web4.0-cil libmono-webmatrix-data4.0-cil
    libmono-windowsbase3.0-cil libmono-windowsbase4.0-cil libnunit-cil-dev libnunit2.6-cil mono-csharp-shell mono-devel mono-dmcs mono-xbuild monodevelop monodoc-base monodoc-manual
    0 actualizados, 113 se instalarán, 0 para eliminar y 0 no actualizados.
    Necesito descargar 29,6 MB de archivos.
    Se utilizarán 74,7 MB de espacio de disco adicional después de esta operación.

Viewing 4 posts - 1 through 4 (of 4 total)
Reply To: TypeLoadException running PabloDraw 3.1.2 in Ubuntu 12.04 64-bit
Your information: